Giuseppe Foza
Criador Giuseppe Foza 03/08/2022

Erro ao instalar o pacote no Laravel 8.

Problem 1

    - Only one of these can be installed: illuminate/queue[v5.4.0, ..., 5.8.x-dev, v6.0.0, ..., 6.x-dev, v7.0.0, ..., 7.x-dev, v8.0.0, ..., 8.x-dev, v9.0.0-beta.1, ..., 9.x-dev], laravel/framework[v8.12.0, ..., 8.x-dev]. laravel/framework replaces illuminate/queue and thus cannot coexist with it.

    - vladimir-yuldashev/laravel-queue-rabbitmq[v12.0.0, ..., v12.0.1] require illuminate/queue ^9.0 -> satisfiable by illuminate/queue[v9.0.0-beta.1, ..., 9.x-dev].

    - Root composer.json requires vladimir-yuldashev/laravel-queue-rabbitmq ^12.0 -> satisfiable by vladimir-yuldashev/laravel-queue-rabbitmq[v12.0.0, v12.0.1].

 

    - Root composer.json requires laravel/framework ^8.12 -> satisfiable by laravel/framework[v8.12.0, ..., 8.x-dev].

 

Criador Giuseppe Foza 03/08/2022

Extensão "sockets" já está instalada no ambiente. Também já fiz rebuild.

Giuseppe Foza
Manager Carlos Ferreira 03/08/2022

Olá, Giuseppe!
Tudo bem?

Seu setup é Docker também?

Tem no GitHub?

Antes de instalar, experimenta atualizar os packages:
composer update

Carlos Ferreira
Criador Giuseppe Foza 03/08/2022

Olá. Consegui resolver instalando a versão 11.3 do pacote. Pode ser questão de compatibilidade com o Laravel 8.

Giuseppe Foza
Sabe a Solução? Ajude a resolver!

Precisa estar logado para conseguir responder a este ticket!

Clique Aqui Para Entrar!